Return to Q&A Database

Numan Athletics color test, no game

Question from Christopher: I have a Numan Athletics (Namco NA-2) motherboard but it is not working. When I switch it on, I get a blue screen / sometimes green / sometimes pink / sometimes red but the game does not work. I recently acquired a new Numan Athletics ROM board. So, I tried that but the same things happen so it has to be the NA-2 motherboard that’s the problem. Could you advise me on where on the board would be the problem and what would I need to do to fix it? The board did work a long time ago but the colors / picture was not good. Now, it doesn’t work at all. Please, please could you give me some advice on this subject as I cant find anything online about it? Many thanks and hope to hear from you soon.

1 answer

Jonathan Leung Jonathan Leung Staff August 7, 2018
Public

Response from Jonathan: Christopher,

The very first thing we recommend doing is checking your power supply to make sure the board is getting the proper voltage. Improper voltage can definitely cause issues with the game booting up which sounds like what maybe happening with your board. Also, the Namco NA-2 boards are notorious for bad caps. We highly recommend replacing all of the caps on the board as well. Don’t forget about the one cap that’s located under the ROM board as this is sometimes overlooked. While you’re replacing the caps on the board, make sure you reflow the solder on the large custom surface mounted chip. The solder on this chip tends to get brittle over time which causes problems. Now, it’s possible that the processor has gone bad but this is a rarity in our experience. Try the cap kit and solder reflow first and then start suspecting the processor if the issues continue.

Hope that helps. Thank you for your question and good luck with your repair.

#1

This question has been closed